This is the documentation for the latest (master) development branch of Zephyr. If you are looking for the documentation of previous releases, use the drop-down menu on the left and select the desired version.
choice WIFI_ESP_AT_VERSION: AT version

AT version

Type: bool

Help

Select which version of AT command set should be used.

Direct dependencies

(WIFI_ESP && NETWORKING && (SHIELD_ESP_8266 || SHIELD_ESP_8266_ARDUINO || SHIELD_ESP_8266_MIKROBUS)) || (WIFI_ESP && NETWORKING && (SHIELD_ESP_8266 || SHIELD_ESP_8266_ARDUINO || SHIELD_ESP_8266_MIKROBUS)) || (WIFI_ESP && WIFI)

(Includes any dependencies from ifs and menus.)

Kconfig definitions

At boards/shields/esp_8266/Kconfig.defconfig:14

Included via Kconfig:8Kconfig.zephyr:23

Menu path: (Top)

choice WIFI_ESP_AT_VERSION
    bool
    default WIFI_ESP_AT_VERSION_1_7
    depends on WIFI_ESP && NETWORKING && (SHIELD_ESP_8266 || SHIELD_ESP_8266_ARDUINO || SHIELD_ESP_8266_MIKROBUS)

At boards/shields/esp_8266/Kconfig.defconfig:14

Included via Kconfig:8Kconfig.zephyr:24

Menu path: (Top)

choice WIFI_ESP_AT_VERSION
    bool
    default WIFI_ESP_AT_VERSION_1_7
    depends on WIFI_ESP && NETWORKING && (SHIELD_ESP_8266 || SHIELD_ESP_8266_ARDUINO || SHIELD_ESP_8266_MIKROBUS)

At drivers/wifi/esp/Kconfig.esp:60

Included via Kconfig:8Kconfig.zephyr:32drivers/Kconfig:74drivers/wifi/Kconfig:35

Menu path: (Top) → Device Drivers → add support for Wi-Fi Drivers → Espressif ESP8266 and ESP32 support

choice WIFI_ESP_AT_VERSION
    bool "AT version"
    default WIFI_ESP_AT_VERSION_2_0
    depends on WIFI_ESP && WIFI
    help
      Select which version of AT command set should be used.

(The ‘depends on’ condition includes propagated dependencies from ifs and menus.)